Incident - Système Téléphonique
Incident Report for Petal - Xacte
Resolved
Le système téléphonique est de nouveau opérationnel.

--------------------------------------------------------------------

This incident has been resolved. All systems are operational.
Posted Mar 09, 2022 - 13:07 EST
Investigating
Nous éprouvons actuellement des difficultés avec notre système téléphonique, affectant notre capacité à acheminer les appels à nos équipes de support. Nous vous invitons à nous envoyer un courriel à aide@xacte.net pour la facturation médicale ou support@petalmd.com pour tout autre problème.
Merci de votre compréhension.

We are currently experiencing issues with our telephone system, affecting our capacity to transfer calls to our support teams. We invite you to e-mail us at help@xacte.net for medical billing or support@petalmd.com for any other issues.
Thank you for your understanding.
Posted Mar 08, 2022 - 12:25 EST